MDrivenWiki
Log in

.net version

From MDrivenWiki

Recently(2018-07-11) the core assemblies of MDriven (Eco.Handles and Eco.Interfaces) was updated from .net4 to .net4.5

The main reason was the Transport Layer Security protocol (TLS) that replaced the legacy SSL protocol - TLS is in Azure now defaulted to TLS1.2 and in order for us to support that we need .net Framework 4.5.

You may experience compilation errors if your solutions compile with .net versions older than 4.5

To fix this update the .net Framework version to at least 4.5 on your projects.

2018-07-11 11h32 03.png
If you write code that all of a sudden does not want to connect with MDriven over https then consider to add this initialization:
System.Net.ServicePointManager.SecurityProtocol = SecurityProtocolType.Tls | SecurityProtocolType.Tls11 | SecurityProtocolType.Tls12;